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1. Installation Process 
 

To install the extension, you need to follow below steps 

 

• Backup your web directory and store database 

• Enable all cache from admin (System > Tools > Cache Management) before upload 

extension. 

• Extract extension zip package and copy folder (app). 

• Upload (app) folder to your store root folder by FTP. 

• After uploading (app) folder navigate to your store root folder in the SSH console of your 

server: 

o Go to root of your Magento installation. 

o Run the following command: 

▪ composer require hybridauth/hybridauth:~3.0 

▪ php bin/magento setup:upgrade 

▪ php bin/magento setup:static-content:deploy -f 

▪ php bin/magento cache:flush 

• Logout to complete installation process and login.  
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http://www.pixlogix.com/


 
6  Go to: Table of Contents Copyright 2022 © Pixlogix.com 

 © Pixlogix.com 

2. Social Login Configuration 
  

2.1 General Settings 

 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login 

• Enable Social Login: To enable or disable social login extension. 

• Send Password To Customer: It will send your password on your social account mail id.  

• Popup Login: To enable or disable popup social login at frontend on sign in button. 

• Display Social Login Buttons on:  The admin can enable or disable social login buttons to 

the particular page on frontend. 

http://www.pixlogix.com/
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2.2 Social Platforms 
 

 

 

In these sections allow enabling/disabling particular social applications for logging-in purposes and store 

appropriate consumer keys and secrets keys. 

Admin can configure and enable or disable particular social login applications from here. It will display to 

the website frontend.  
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http://www.pixlogix.com/


 
8  Go to: Table of Contents Copyright 2022 © Pixlogix.com 

 © Pixlogix.com 

3.  Facebook 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > 

Facebook 

• Enable Facebook [Yes / No]: Enable/Disable Facebook Login. 

http://www.pixlogix.com/
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• Facebook Consumer Key (API Key) and Facebook Consumer Secret (API Secret) can be found 

when configuring the Facebook Login API by following the configuration steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You can 

copy from admin panel. 

 

3.1 Step 1: Facebook API Configuration 
 

 

 

 

• Register as a Facebook Developer :- https://developers.facebook.com/apps  

Or you can click on Create app here from admin. 

• And login with your Facebook account. 

• Click on Create App and fill the details. 

• Select an app type as Consumer. 

http://www.pixlogix.com/
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3.2 Step 2 
 

 
 

• Find the Facebook Login and click on Set Up.  
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3.3 Step 3 
 

 
 

• Here, select web platform for this app. 
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3.4 Step 4  

 

 
• Here, you have to write site URL. 

http://www.pixlogix.com/
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3.5 Step 5 
 

 

• You will see that Facebook Login has been added under Products. Click on it and 

select Settings from the dropdown menu. 

• We will be adding Valid OAuth Redirect URIs, which we can find in the Magento  2 Admin 

under Pixlogix Extensions > Social Login  > Social Platforms > Facebook   > Redirect Uri. 

3.6 Step 6 

 

 

• Here, you need to add Permissions:  

o Click on Permissions and Features > public_profile  and click on Get Advanced Access 
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3.7 Step 7 

 

 

 

• Here, you need to add Permissions and Features:  

o Click on Permissions and Features > email and click on Get Advanced Access  
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3.8 Step 8 

 

 
 

• Finally, we will get the Consumer Key (API Key) and Consumer Secret (API Secret). To do this, from the 

menu on the left hand side, select Settings, and from the dropdown, select Basic. 

• Remember to also fill out the Privacy Policy and Terms of Service URLs. 

• Take the Consumer Key (API Key) and Consumer Secret (API Secret) (you can also fill in the rest of the 

details on this page) and enter them into the Magento Admin under the respective fields. 

o Note: The Privacy Policy URL is required for the app to go Live. 
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3.9 Step 9  

 

 
 

Set the App Status to Live. 

• Add app icon. 

• Select category as utility & productivity. 

• Save and you the configuration should be done. 

• Fill all the required fields for change application mode from Development to Live. 
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4. Twitter 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms 

>Twitter 

• Enable Twitter [Yes / No]:  Enable/Disable Twitter Login. 

http://www.pixlogix.com/
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• Twitter Consumer Key (API Key) and Twitter Consumer Secret (API Secret) can be found when 

configuring the twitter Login API by following the configuration steps below. 

• Redirect Uri:  This URL should be used while creating a new Social Login application. You can 

copy from admin panel. 

 

4.1 Step 1: Twitter API Configuration 
 

 
 

 
• Register as a Twitter Developer :-  https://developer.twitter.com/en/portal/projects-and-apps 

Or you can click on Create app here from admin. 

• And login with your Twitter account. 

• Click on Create App and fill the details. 
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4.2 Step 2 

 

 
 

• Here, you need set your app name. 
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4.3 Step 3 
 

 
 

• After Key and tokens box will generate. 

• Get the API key and API secret key and enter them into their respective fields in the Magento 

Admin. 

• Note: Once API key and API secret generated after you need to copy and paste them in your file 

because you can’t able to see that twice and you have to re-generate it. 

• Save the configuration and you should be done. 
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5. Google 
 

 

 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Platforms > Social Login > 

Google 
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• Enable Google [Yes / No]: Enable/Disable Google Login. 

• Google Consumer Key (API Key) and Twitter Consumer Secret (API Secret) can be found 

when configuring the Google Login API by following the configuration steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You can 

copy from admin panel. 

5.1 Step 1: Google API Configuration 
 

 

• Register as a Google Developer :-  https://console.cloud.google.com/project 

Or you can click on Create app here from admin. 

• And login with your Google account. 

• Click on Create Project and fill in the required details. 
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5.2 Step 2 

 

 
 

• Click on the Navigation menu on the left hand side. 

• Choose APIs & Services and click on the Credentials. 

http://www.pixlogix.com/
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5.3 Step 3 

 

 
 

• Open CREATE CREDENTIALS. 

• Click on the Create OAuth client ID. 
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5.4 Step 4 
 

 

• Here, you have to select Application Type. 

• And select as Web Application. 

• Create name for your application. 

• Create Authorized JavaScript origins (Domain Url) and Authorized redirect URIs. 

o Under Authorized redirect URIs, enter the URI found in Magento Admin > Pixlogix 

Extensions > Social Login > Social Platforms > Google > Redirect Uri 

• Click Create. 
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5.5 Step 5 
 

 

• You'll then be presented with your Client ID and Client Secret. 

• Copy those and paste them into their respective fields in the Magento Admin. 

• Save the configuration and you should be done. 

5.6 Step 6 
 

 

• After you can find Client ID and Client Secret on the right hand side.  

http://www.pixlogix.com/
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6. LinkedIn 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > 

LinkedIn 

   

• Enable LinkedIn [Yes / No]: Enable/Disable LinkedIn Login. 

http://www.pixlogix.com/
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• LinkedIn Consumer Key (API Key) and LinkedIn Consumer Secret (API Secret) can be found 

when configuring the LinkedIn Login API by following the configuration steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You can 

copy from admin panel. 

 

6.1 Step 1: LinkedIn API Configuration 
 

 

 

• Register as a LinkedIn Developer :-  https://developer.linkedin.com/ 

Or you can click on Create app here from admin. 

• And login with your LinkedIn account. 
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6.2 Step 2 
 

 

• Fill out the App fields. 

• Make sure you fill out the Privacy Policy URL. 

• Click on Create App. 
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6.3 Step 3 
 

 

 

• To get OAuth 2.0 scopes you have to click in Select. 
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6.4 Step 4 
 

 

 

• Now, you can able to see these two OAuth 2.0 scopes. 

• Permissions make sure you have the r_basicprofile and r_emailaddress. 
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6.5 Step 5 
 

 

• Under Authentication, you'll have the Client ID and Client Secret. Enter those into their 

respective fields in the Magento Admin. 

• Fill in the Authorized redirect URLs for your app with the URI generated under Admin > 

Pixlogix Extensions > Social Login > Social Platforms > LinkedIn > Redirect Uri. 

• Save the configuration and you should be done. 
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7.   Amazon 
 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > 

Amazon 

• Enable Amazon [Yes / No]:  Enable/Disable Amazon Login.  

• Amazon Consumer Key (API Key) and Amazon Consumer Secret (API Secret) can be 

found when configuring the Amazon Login API by following the configuration steps 

below. 

http://www.pixlogix.com/
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• Redirect Uri:  This URL should be used while creating a new Social Login application. You 

can copy from admin panel. 

7.1 Step 1: Amazon API Configuration 
 

 

 

• Register as a Amazon Developer :  https://developer.amazon.com/ 

Or you can click on Create app here from admin. 

• And login with your Amazon account. 
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7.2 Step 2 
 

 

 

• Click on Login with Amazon. 
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7.3 Step 3 
 

 

 

• Click on Create a New Security Profile. 

 

7.4 Step 4 
 

 

• Fill out the necessary details required by the form. 

• Click on Save. 

http://www.pixlogix.com/
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7.5 Step 5 
 

 

 

7.6 Step 6 
 

 

• Here, you have to click on setting button and select as Web Settings. 

• Copy your Client ID and Client Secret and paste them into their respective fields in the Magento 
Admin. 
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7.7 Step 7 
 

 

• Enter the Allowed Origins as your site domain name. 

• Enter Allowed Return URL you will found in the Magento Admin > Pixlogix Extensions > Social 

Login > Social Platforms > Amazon  > Redirect Uri 
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7.8 Step 8 
 

 

 

• Click on Allow button and finally you are done. 
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8.   GitHub 
 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Platforms > Social Login > 

GitHub 

• Enable GitHub [Yes / No]: Enable/Disable GitHub Login. 

• GitHub Consumer Key (API Key) and GitHub Consumer Secret (API Secret) can be found 

when configuring the Github Login API by following the configuration steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You 

can copy from admin panel. 

http://www.pixlogix.com/
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8.1 Step 1: GitHub API Configuration 
 

 

• Register as a GitHub Developer :- https://github.com/settings/apps 

Or you can click on Create app here from admin. 

• And login with your GitHub account. 

• Click on New GitHub App. 
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8.2 Step 2 
 

 

• Enter your details. 

• Enter your Homepage URL. 

• Enter the Authorization callback URL found in the Magento Admin  > Pixlogix Extensions  > 

Social Login > Social Platforms > GitHub > Redirect Uri 
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8.3 Step 3 
 

 

 

• Go to General and open your application. 

• Copy your Client ID and Client Secret and paste them into their respective fields in the Magento 

Admin. 

• Save the configuration and you should be done. 
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9.   Yahoo 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > Yahoo 

• Enable Yahoo [Yes / No] : Enable/Disable Yahoo Login. 

• Yahoo Consumer Key (API Key) and Yahoo Consumer Secret (API Secret) can be found 

when configuring the Yahoo Login API by following the configuration steps below. 

http://www.pixlogix.com/
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• Redirect Uri: This URL should be used while creating a new Social Login application. You 

can copy from admin panel. 

9.1 Step 1: Yahoo API Configuration 
 

 

 

• Register as a Yahoo Developer :-  https://developer.yahoo.com/apps/create/ 

Or you can click on Create app here from admin. 

• And login with your Yahoo account. 

• Enter your details. 

• Enter your Homepage URL. 

• Go to api Permissions and select as OpenID Connect Permissions (checked) > email (checked) > 

profile (checked). 

Note: as per given screen short.  

http://www.pixlogix.com/
http://www.pixlogix.com/
https://developer.yahoo.com/apps/create/


 
46  Go to: Table of Contents Copyright 2022 © Pixlogix.com 

 © Pixlogix.com 

9.2 Step 2 
 

 

 

• Enter the Redirect URI(s) found in the Magento Admin > Pixlogix Extensions > Social Login > 

Social Platforms > Yahoo > Redirect Uri. 

• Copy your Client ID and Client Secret and paste them into their respective fields in the Magento 

Admin. 

• Save the configuration and you should be done. 
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10.    Foursquare 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > 

Foursquare 

• Enable Foursquare [Yes / No]:  Enable/Disable Foursquare Login. 
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• Foursquare Consumer Key (API Key) and Foursquare Consumer Secret (API Secret) can 

be found when configuring the Foursquare Login API by following the configuration 

steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You 

can copy from admin panel. 

 

10.1 Step 1: Foursquare API Configuration 
 

 

 

• Register as a Foursquare Developer :-  https://foursquare.com/developers/projects 

• Or you can click on Create app here from admin. 

• And login with your foursquare account. 

• Click on Create New Project. 
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10.2 Step 2 
 

 

 

• Enter your Project URL and Privacy Policy URL. 

• Enter the Redirect URI(s) found in the Magento Admin > Pixlogix Extensions > Social Login > 

Social Platforms > Foursquare > Redirect Uri. 
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10.3 Step 3   
 

 

 

• Copy your Client ID and Client Secret and paste them into their respective fields in the Magento 

Admin. 

• Save the configuration and you should be done. 
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11. Disqus 
 

 

 

Go to Admin > Stores > Configuration > Pixlogix Extensions > Social Login > Social Platforms > Disqus 

  

• Enable Disqus [Yes / No]:  Enable/Disable Disqus Login. 
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• Disqus Consumer Key (API Key) and Disqus Consumer Secret (API Secret) can be found 

when configuring the Disqus Login API by following the configuration steps below. 

• Redirect Uri: This URL should be used while creating a new Social Login application. You 

can copy from admin panel. 

11.1 Step 1:  Disqus API Configuration 
 

 

 

• Register as a Discus Developer :-  https://disqus.com/api/applications/ 

• Or you can click on Create app here from admin. 

• And login with your Disqus account. 

• Click on Register new application. 

 

 

 

http://www.pixlogix.com/
http://www.pixlogix.com/
https://disqus.com/api/applications/


 
53  Go to: Table of Contents Copyright 2022 © Pixlogix.com 

 © Pixlogix.com 

11.2 Step 2 
 

 

 

• Enter you details. 
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11.3 Step 3 
 

 

• Select default access as Read and Write. 

• Enter Terms of Service URL. 
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11.4 Step 4 
 

 

• After you will get permission like this. 
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11.5 Step 5 
 

 

• Enter the Callback URL found in the Magento Admin > Pixlogix Extensions > Social Login > 

Social Platforms > Disqus > Redirect Uri. 

• Copy your Client ID and Client Secret and paste them into their respective fields in the Magento 

Admin. 

• Save the configuration and you should be done. 
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12. Customer Social Accounts 
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Another section the extension introduces to the store backend is Customer Social 

Accounts found under Customers → Social Login → Social Login Accounts. 

 

13. Frontend View 
 

 

The Pixlogix Social Login extension is ready for work right after installation. It comes with a set of Display 

Social Login Buttons on that can be enabled separately for register, login, shopping cart, and checkout 

pages. 
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The buttons can contain up to nine login buttons:  Facebook, Twitter, Google, LinkedIn, Amazon, GitHub, 

Yahoo, Foursquare and Disqus. With the social login buttons, customers can log in to a website with one 

click. 

 

 

 

 

 

Popup View 
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14. Customer Area 

 

 

• Here, at the frontend of the store, the Social Login extension introduces the My Social Accounts 
customer account section. 

• In this section, customers can view and manage their social accounts by unlinking current ones. 
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Help & Support 

 

Please read "User Guide" carefully, it will help you to resolve most of potential problems with 

incorrect configuration of the extension in Magento.  

Magento Support Policy 

Magento configuration, installation, maintenance, customization etc. is beyond the scope of our 

support. We can provide you paid support on extension setup, customization & magento custom 

requirement. If you found bug within extension, please contact us at below email.  

 

support@pixlogix.com 

 

Developed by 

 

PIXLOGIX INFOTECH PVT. LTD. is a multi-disciplinary, award-winning web design, development and user 

experience company with special focus on website usability and responsive design. The PIXLOGIX team 

consists of a highly experienced team of specialists with an outstanding record of providing high quality 

deliverables both on a timely basis and at very affordable cost. 

 

PIXLOGIX is a Global provider of web programming and IT services with clients based in the USA, UK, 

Australia, Finland, Spain, Netherlands and many more. Our communication skills are excellent and are 

pleased to participate in providing quotations per Requests for Quotation or proposals. We guarantee 

your satisfaction! 

 

www.pixlogix.com 

Thank you! 
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